Bienvenido al sistema de Preguntas y Respuestas de DesdeLinux.net Si tienes alguna duda o pregunta sobre GNU/Linux, siéntete libre de compartirla acá. Entre todos te ayudaremos. Antes de empezar, te sugerimos que le pegues un vistazo a nuestra guía de preguntas frecuentes (FAQ, en inglés) para entender cómo funciona Ask DesdeLinux.

Avería intermitente con encendido de la pantalla del PC

0 votos
Hola a [email protected],

Hace dos semanas compré una torre de sobremesa a mis padres por muerte del anterior, totalmente nuevo salvo los dos HDD que tenía el otro y que funcionaban bien y son SATA3, y ya me preocupé de que el núcleo fuera Intel (es un i3-4150 a 3.50GH) por la mejor compatibilidad con Linux (sobretodo a nivel de gráficos).

Su gráfica es la HD 4400 integrada con la CPU y el problema que tenemos es que en ocasiones (no siempre pasa), al encender el PC, oyes como arma, ves todas las luces de la torre en marcha y girar los HDD y ventiladores, pero la pantalla no "engancha" en el arranque y se queda en negro con el testigo de encendido parpadeando. Lo solucionamos apretando el botón de encendido hasta que se apaga, lo volvemos a encender, y ya va, y el funcionamiento es bueno durante toda la sesión.

Esto mismo también lo hace en ocasiones con el ahorro de energía donde se apaga la pantalla y, por mucho que muevas el ratón, tenemos que actuar igual.

Instalé los drivers de Intel de la web (la versión 1.0.6, porque la 1.0.7 de esta semana aún no he podido) y sigue haciendo lo mismo.

Les he instalado Xubuntu 14.04.1 64bits por sencillez y agilidad (yo lo gasto desde hace 2 años, y lo tengo en tres PC's y va perfecto) y ya no se me ocurre nada más, salvo que pudiera ser un problema de Hardware. Pero tengo miedo de ir a la tienda y que me vengan con tonterias de quererme meter el Windows porque, por desgracia y aunque suelen hablar bien de Linux, para la mayoría es un desconocido y así acaban rápido. ¿Alguna sugerencia a nivel de software o creéis que puede ser problema de hardware (gráfica o placa base)? ¿Cómo podría testearlo para asegurarme al ir a la tienda y pedir el cambio de componente? (Deciros que el monitor ha ido perfecto hasta el cambio de torre, y con otro monitor también hizo lo mismo. Además, llevo 5 años con Linux y a mi nunca me pasó nada parecido ni vi nada en los foros y mis conocimientos no son muy grandes en el tema).

Gracias de antemano a todos. Llevo siguiendo esta web desde hace mucho tiempo y es una maravilla.

Un saludo!
preguntado por tioposi Nov 14, 2014 en Hardware
Compartir esta pregunta:

1 Respuesta

0 votos
Mirá, es muy sencillo, yo utilizaría el siguiente criterio:

1. Si la pantalla en negro aparece desde el segundo que prendés la máquina, entonces es un error de hardware.

2. Si la pantalla en negro aparece justo cuando debería aparecer GRUB, entonces puede ser un error de GRUB.

3. Si la pantalla en negro aparece después de haber seleccionado Xubuntu en el GRUB, entonces hay grandes chances de que sea un error de software.

Si no entiendo mal, en tu caso sucede lo descripto en el punto 1, con lo cual casi seguro que es un error de hardware, con lo cual es difícil de ayudarte a la distancia sin ver y probar los componentes. De todas formas, yo recuerdo que a veces, por las subidas o bajadas de tensión la máquina podía "marearse" y no terminaba de prender.

En ese momento lo solucioné haciendo lo siguiente:

1. Apagar la PC
2. Desconectar la energía y presionar el botón de apagado (si lo tiene) que hay detrás (no es el de inicio que está adelante!)
3. Esperar 30 segundos y presionar 2-3 veces el botón de inicio para eliminar energía residual
4. Volver a conectar todo
5. Pulsar el botón de inicio
respondido por usemoslinux (3,428 puntos) Nov 15, 2014
Muchas gracias por tu respuesta.
Se lo dije a mi padre y dice que hace dos días, después de "tocar" algo del protector de pantalla y ahorro de energía, que ya no le pasa.
No las tengo todas conmigo pero bueno...en cuanto vuelva a pasar, probaré lo que comentas pero me decantó por problema de Hardware aunque me gustaría saber como se puede testear si es la GPU o que.
Si encuentro cualquier otra solución, lo comentaré! ;-)
Buenas!
Después de llevarlo a la tienda, y tras testearlo todo, me dijeron que en Windows no lo hacía y es un problema de controladores. El problema lo hace con la salida DVI ya que parecer ser que con la VGA no es así, y en internet hay muchos post (la mayoría de hace ya algunos años) donde reportaban ese problema. A nivel gráfico no he visto qué más podría hacer o intentar, por lo que tengo que acabar en la terminal para intentar solucionarlo. Parece ser que esta pasaría por reiniciar el servidor gráfico (el xserver) y reconfigurarlo de nuevo (sobretodo el apartado de las salidas y configuración del monitor)
¿Se te ocurre alguna propuestam sugerencia o alternativa para reparar el tema DVI?
Gracias de nuevo!
Siguiendo el criterio de mi respuesta: la pantalla negra te aparece después de mostrar la información del BIOS? Llegás a ver algo al arrancar la máquina? O desde el instante en que apretás el botón de encendido se ve todo negro?
Llego a verlo todo e incluso trabajar con normalidad. Pero se pone el ahorro de energía o el protector de pantalla, o simplemente desconectar o conectar el cable, y casi el 95% de las veces se queda en negro la pantalla.
Ah! Probá con esto: andá al "Administrador de Energía" (Power Manager), hacé clic en la pestaña "Con AC" (On AC) y luego en "Monitor". Cambiá el ajuste "Apagar la pantalla cuando el equipo está inactivo" a "Nunca".
Reiniciá la máquina y fijate si todo funciona como debería. :)
...