Bienvenido al sistema de Preguntas y Respuestas de DesdeLinux.net Si tienes alguna duda o pregunta sobre GNU/Linux, siéntete libre de compartirla acá. Entre todos te ayudaremos. Antes de empezar, te sugerimos que le pegues un vistazo a nuestra guía de preguntas frecuentes (FAQ, en inglés) para entender cómo funciona Ask DesdeLinux.

Problema al instalar SDK Huella digital

0 votos
Hola a todos.
alguien a logrado instalar el sdk digital person en debian 7 o 8.
Es que no he podido instalarlo ni en debian, ubuntu o mint.
El error que me marca es el siguiente:
rm -fr mod_usbdpfp.o mod_usbdpfp.ko mod_usbdpfp.*.* .mod_usbdpfp.* .tmp_versions* .*.cmd *.o *~ *.order *.symvers
make -C /lib/modules/3.16.0-4-amd64/build M=/opt/DigitalPersona/drivers/source/usbdpfp modules
make[1]: Entering directory '/usr/src/linux-headers-3.16.0-4-amd64'
Makefile:10: *** mixed implicit and normal rules: deprecated syntax
make[1]: Entering directory `/usr/src/linux-headers-3.16.0-4-amd64'
CC [M] /opt/DigitalPersona/drivers/source/usbdpfp/usbdpfp.o
In file included from /opt/DigitalPersona/drivers/source/usbdpfp/usbdpfp.c:120:0:
/opt/DigitalPersona/drivers/source/usbdpfp/usbdpfp.h:19:28: fatal error: linux/smp_lock.h: No existe el fichero o el directorio
#include <linux/smp_lock.h>
^
compilation terminated.
/usr/src/linux-headers-3.16.0-4-common/scripts/Makefile.build:262: recipe for target '/opt/DigitalPersona/drivers/source/usbdpfp/usbdpfp.o' failed
make[4]: *** [/opt/DigitalPersona/drivers/source/usbdpfp/usbdpfp.o] Error 1
/usr/src/linux-headers-3.16.0-4-common/Makefile:1350: recipe for target '_module_/opt/DigitalPersona/drivers/source/usbdpfp' failed
make[3]: *** [_module_/opt/DigitalPersona/drivers/source/usbdpfp] Error 2
Makefile:181: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-3.16.0-4-amd64'
Makefile:23: recipe for target 'compile' failed
make: *** [compile] Error 2

Agradezco mucho su amable atención, ojala puedan orientarme de como solucionarlo.
Mil gracias!!!
preguntado por Mario Jun 29, 2015 en Debian - LMDE
Compartir esta pregunta:

2 Respuestas

0 votos
Amigo.

Lo que sucede es que no has instalado el paquete heards de la version del kernel
que tienes intalado en tu equipo.Ademas necesitas instalar paquetes como:cmake,buils-essencials y dmks.

Si todo esta correcto deberias tener una carpeta llamada builds en el directorio /libs/modules/"vercion del kernel"/builds.

espero que te ayude.
respondido por Juan David Mar 8, 2016
0 votos
Lo que pasa que el SDK de digital personas lo hicieron varios años atrás y funcionaba con ubuntu 10 y openSuse 12 que traían el kernel 2.x
Por lo cual no te funciona.
No se si algún día vayan a sacar una versión actualizada del software de huella digital.
respondido por daniel Mar 9, 2016
...