Bienvenido al sistema de Preguntas y Respuestas de DesdeLinux.net Si tienes alguna duda o pregunta sobre GNU/Linux, siéntete libre de compartirla acá. Entre todos te ayudaremos. Antes de empezar, te sugerimos que le pegues un vistazo a nuestra guía de preguntas frecuentes (FAQ, en inglés) para entender cómo funciona Ask DesdeLinux.

Problema con driver escanner multifunción Epson L355

0 votos
Hola, Mi sistema operativo es Lubuntu
No puedo instalar el driver oficial (iscan_2.30.1-1~usb0.1.ltdl3_i386.deb) del escanner de la impresora (Epson l355), ya que al hacerlo con el instalador GDebi el siguiente error aparece: "no se puede satisfacer la dependencia iscan-data"
La primera vez que intenté instalarlo el instalador me sugirión instalar un programa llamdo "Lintian" por terminal. Lo hice y ahora en una de las pestañas de opciones del instalador me sale el siguiente texto de error:
W: iscan: package-name-doesnt-match-sonames libesmod2
W: iscan: hardening-no-relro usr/bin/iscan
W: iscan: hardening-no-relro usr/lib/libesmod.so.2.0.0
W: iscan: hardening-no-relro usr/lib/sane/libsane-epkowa.so.1.0.15
W: iscan: maintainer-script-ignores-errors postrm
W: iscan: maintainer-script-ignores-errors postinst
W: iscan: maintainer-script-ignores-errors preinst
W: iscan: maintainer-script-ignores-errors prerm
E: iscan: non-empty-dependency_libs-in-la-file usr/lib/sane/libsane-epkowa.la

Lintian finalizó con el estado de salida 1


Por las dudas aclaro que Simple scan no me detecta el scanner. Si alguien me puede dar una mano se lo agradeceré
preguntado por Carlos Mar 4, 2015 en Hardware
Compartir esta pregunta:

1 Respuesta

0 votos
es un problema de dependencias, hay que instalar el paquete que te pide primero iscan-data Your text to link here... quizas los que hay ahi te sirvan
respondido por fabianpa (740 puntos) Mar 4, 2015
Hola, muchas gracias por tu respuesta. Al instalar la dependencia (gracias por el link!) y correr nuevamente el driver del escanner, me sale nuevamente el mismo error pero con otra dependencia, en este caso libltdl3. Buscando un largo rato encontre un hilo (https://bugs.launchpad.net/ubuntu/+bug/208405) en Launchpad, aunque realmente no lo entndi.
Al parecer esta dependencia no se puede instalar o al menos no pude encontrarla. En mi sistema tengo instalada libltdl7 que supuestamente reemplaza a la que mencione, pero de todas formas no puedo correr el driver del escanner. Gracias por tu tiempo
no se donde te da el problema de dependencias a veces s se arregla mandando un enlace simbolico de en este caso /usr/lib/x86_64-linux-gnu/libltdl.so.7
...