Bienvenido al sistema de Preguntas y Respuestas de DesdeLinux.net Si tienes alguna duda o pregunta sobre GNU/Linux, siéntete libre de compartirla acá. Entre todos te ayudaremos. Antes de empezar, te sugerimos que le pegues un vistazo a nuestra guía de preguntas frecuentes (FAQ, en inglés) para entender cómo funciona Ask DesdeLinux.

No actualizar kernel hasta que la actualizacion de un modulo este disponible para él

0 votos
Hola a todos y felices fiestas. Actualmente uso openSUSE thumbleweed y cada vez que se actualiza el kernel me deja de funcionar un tiempo hasta que aparece el módulo broadcom-wl.

Mi pregunta es la siguiente: hay alguna forma de que el kernel no se actualice hasta que este modulo esté disponible para él? O sea, crearle una dependencia directa en mi sistema.

Gracias.
preguntado por teoj (172 puntos) Dic 31, 2014 en openSUSE
Compartir esta pregunta:
No entiendo bien la pregunta. Qué es exactamente lo que pasa con el módulo broadcom-wl? Al arrancar el sistema se te cuelga la máquina hasta que carga ese módulo y después sigue todo bien? Es eso?
No. Lo que pasa es que el modulo no esta. O sea estaba para el 3.17 pero para el 3.18 aun no esta y por tanto no tengo WiFi.
Gracias.

2 Respuestas

+1 voto
Bueno, creo que en OpenSUSE al igual que en todas las distros GNU/Linux (también en Thumbleweed) existe un paquete llamado "dkms" (Dynamic Kernel Module Support) que permite que cada vez que se actualice el kernel se mantengan aquellos módulos que no se actualizan de inmediato, o sea es una forma de no perder los módulos aun cuando el kernel se actualice. (http://es.wikipedia.org/wiki/Dynamic_Kernel_Module_Support)

Instálalo y actualiza el sistema, verás que el módulo "broadcom-wl" se mantendrá aunque el kernel se actualice.

http://software.opensuse.org/package/dkms

Espero te sirva. ;)
respondido por linuXgirl (458 puntos) Ene 6, 2015
editado por linuXgirl Ene 6, 2015
0 votos
Abrí YaST > Actualización en línea> hacé clic derecho en el paquete en cuestión y seleccioná la opción "proteger" en el menú. De ese modo, el paquete seleccionado no se actualizará, a pesar de que haya nuevas versiones disponibles.

Más info en la documentación de openSUSE.
respondido por usemoslinux (3,428 puntos) Ene 6, 2015
...